UnRiskExcel

1 Prerequisites
•
•
•
•

Windows XP or higher
Microsoft Excel 2003 SP3, 2007 SP2, 2010 (32 or 64-bit) or 2013 (32 or 64-bit)
Mathematica 8 or higher
UnRisk 8.0 or higher

2 Installation
To install UnRiskExcel, both Mathematica and Excel must be configured. UnRiskExcel is
available in different versions, corresponding to the different versions of Excel. The necessary
files are contained in the UnRisk installation directory under UnRisk_for_Excel\AddIn. There
are subdirectories for the different Excel versions, see below.
| UnRisk
| UnRisk_for_Excel
| AddIn
| Excel2003
| Excel2007
| Excel2010-32bit
| Excel2010-64bit
| Excel2013-32bit
| Excel2013-64bit
Each folder contains the files UnRiskExcelVBA.xla and UnRiskExcel.xll.
2.1 Mathematica
In the Mathematica front-end, you need to configure the number of parallel kernels. Start
Mathematica, select Evaluation from the main menu and choose the menu item Parallel
Kernel Configuration. The dialog shown in Figure 1 will open.
On a single-core system, you won’t be able to configure the number of kernels. On multi-core
systems, the displayed number of kernels varies with the number of cores. If you can modify
the configuration, ensure that the number of local kernels is set to Automatic.
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Figure 1: Mathematica parallel kernel configuration dialog

2.2 Excel 2003
Start Excel, and on the Tools menu, click Add-Ins. Excel will open the Add-Ins dialog. Click
Browse and locate your UnRisk directory. Select both files from the
UnRisk\UnRisk_for_Excel\Excel2003 directory and ensure that both Add-Ins are checked.
After installing both UnRiskExcel files, the Add-Ins dialog should look similar to Figure 2.
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Figure 2: Excel Add-Ins dialog

2.3 Excel 2007
For Excel 2007, Service Pack 2 is required for running UnRiskExcel. Click the Microsoft
Office Button
, and click Excel Options. Click at the Add-Ins category. In the Manage
box, select Excel Add-ins, and click Go.
Click Browse and locate your UnRisk directory. Select both files from the
UnRisk\UnRisk_for_Excel\Excel2007 directory and ensure that both Add-Ins are checked.
After installing both UnRiskExcel files, the Add-Ins dialog should look similar to Figure 2.
Excel 2007 can perform multiple calculations in parallel. To use this feature, it must be
configured. Click the Microsoft Office Button
, and click Excel Options. Click at the
Advanced category and scroll down to the section Formulas. Ensure that Enable multithreaded calculation is checked and that Use all processors on this computer is selected.
Figure 3 shows the dialog with the correct settings applied.
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Figure 3: Dialog for activating multi-threaded calculation

2.4 Excel 2010
To determine if you have Excel 2010 32 or 64-bit installed, click the File Menu, and select
Help. The exact version string is in the area on the right, e.g., Version: 14.0.4760.1000 (32
bit). To install the appropriate UnRiskExcel version, click the File Menu, and select Options.
Click at the Add-Ins category. In the Manage box, select Excel Add-ins, and click Go.
Click Browse and locate your UnRisk directory. Depending on the version determined earlier,
navigate either to UnRisk\UnRisk_for_Excel\Excel2010-32bit or the Excel2010-64bit
directory. From the appropriate directory, select both files and ensure that both Add-Ins are
checked. After that, the Add-Ins dialog should look similar to Figure 2.
Excel 2010 can perform multiple calculations in parallel. To use this feature, it must be
configured. Click the File Menu, and select Options. Click at the Advanced category and
scroll down to the section Formulas. Ensure that Enable multi-threaded calculation is
checked and that Use all processors on this computer is selected. Figure 3 shows the dialog
with the correct settings applied.
2.5 Excel 2013
To determine if you have Excel 2013 32 or 64-bit installed, click the File Menu, and select
Help. The exact version string is in the area on the right, e.g., Version: 15.0.4569.1506 (32
bit). To install the appropriate UnRiskExcel version, click the File Menu, and select Options.
Click at the Add-Ins category. In the Manage box, select Excel Add-ins, and click Go.
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Click Browse and locate your UnRisk directory. Depending on the version determined earlier,
navigate either to UnRisk\UnRisk_for_Excel\Excel2013-32bit or the Excel2013-64bit
directory. From the appropriate directory, select both files and ensure that both Add-Ins are
checked. After that, the Add-Ins dialog should look similar to Figure 2.
Excel 2013 can perform multiple calculations in parallel. To use this feature, it must be
configured. Click the File Menu, and select Options. Click at the Advanced category and
scroll down to the section Formulas. Ensure that Enable multi-threaded calculation is
checked and that Use all processors on this computer is selected. Figure 3 shows the dialog
with the correct settings applied.
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3 Updating UnRiskExcel
If you are already using UnRiskExcel and if you only want to update UnRiskExcel without
updating your UnRisk installation, perform the following steps:
1. Close all Excel windows and exit Excel.
2. Locate your UnRisk installation directory and extract UnRiskExcel to
UnRisk\UnRisk_for_Excel. Overwrite already existing files.
Excel 2003: Start Excel, and on the Tools menu, click Add-Ins. Uncheck both
UnRiskExcel Add-Ins
Excel 2007: Click the Microsoft Office Button
, and click Excel Options. Click at the
Add-Ins category. In the Manage box, select Excel Add-ins, and click Go. Uncheck
both UnRiskExcel Add-Ins.
Excel 2010: Click the File Menu, and select Options. Click at the Add-Ins category. In
the Manage box, select Excel Add-ins, and click Go. Uncheck both UnRiskExcel AddIns.
Excel 2013: Click the File Menu, and select Options. Click at the Add-Ins category. In
the Manage box, select Excel Add-ins, and click Go. Uncheck both UnRiskExcel AddIns.
3. Close all Excel windows and exit Excel
4. Restart Excel and perform the normal installation steps (see Section Installation). During
the installation, Excel might ask if the new Add-Ins should replace the existing ones.
Choose Yes.
During the first Excel startup after updating UnRiskExcel might display a warning message to
indicate that your configuration file was corrected. This message is normal.

4 Upgrading Excel
To upgrade to a more recent version of Excel (e.g., to upgrade from Excel 2003 to Excel
2010), please first follow the steps for installing the UnRisk Add-In for your new version of
Excel, see sections 2.2, 2.3 and 2.4 in this guide.
As Excel saves the full path to an Add-In also in workbook formulas that use it, your
UnRiskExcel workbooks need to be updated, too. You do not need to do this by hand: To
update all formulas in a workbook to use the new Add-In, please run “Convert Current
Workbook” from the Add-Ins->UnRisk menu. You can also batch-convert all workbooks in a
directory on your computer with “Add-Ins->UnRisk->Convert Workbooks…”.

5 Usage
5.1 First Startup
UnRiskExcel tries to locate an existing Mathematica installation automatically, so that the
Mathematica installation directory needs not to be configured. Only if UnRiskExcel fails to
locate the Mathematica installation, the user must configure the directory manually. For
details see Section Configuration File.
UnRiskExcel registers the new Excel function UnRisk that is used to invoke UnRisk
calculations. It also adds a new menu UnRisk to the main menu bar. UnRiskExcel replaces
the previously used “Mathematica Link for Excel” and provides an automatic workbook
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conversion that can be executed from the UnRisk menu. After converting the workbooks,
“Mathematica Link for Excel” can be uninstalled if no longer required.
5.2 Parallelization
Normally, calculations are performed one by one but many of nowadays computers can
perform multiple calculations in parallel. UnRiskExcel provides parallel calculation support if
it detects that your computer is capable of performing multiple calculations in parallel. This is
especially efficient for long running calculations and can severely reduce the time required for
calculation.
• For Excel 2003, UnRiskExcel provides multiple commands that allow parallel
calculation of UnRisk formulas within the current workbook, the active sheet or the
active selection. However, there is the following limitation:
o Calculate Workbook in Parallel: UnRiskExcel iterates over all worksheets,
from left to right and calculates each worksheet separately. So, the user must
ensure that formulas never reference worksheets to their right. Otherwise, old
values might be used.
• Excel 2007 natively performs multiple calculations in parallel. However, Excel 2007
has one limitation:
o Formulas using INDIRECT: If a formula uses the worksheet formula	
  
INDIRECT, Excel cannot parallelize the calculation.
• Excel 2010 natively performs multiple calculations in parallel without any known
limitations.
• Excel 2013 natively performs multiple calculations in parallel without any known
limitations.
5.3 Features
UnRiskExcel adds a menu UnRisk to Excel’s main menu and provides the following
commands:
• Start/Stop UnRisk: Starts or stops UnRisk. All calculations that are currently in
progress are aborted when UnRisk is shutdown.
• Convert Current Workbook: Converts the active workbook from “Mathematica
Link for Excel” to UnRiskExcel. All Math(…) and UnRisk(…) functions within Excel
formulas are converted to UnRisk(…). After successful conversion of the workbook, it
must be recalculated.
There is one limitation in this conversion: long array formulas (more than 255
characters) cannot be converted automatically, due to a limitation of Excel.
• Convert Workbooks: This opens a conversion dialog that allows the user to
efficiently convert lots of workbooks to UnRiskExcel.
• Edit Configuration: Opens the configuration file and allows customization of the
settings. See Section Configuration File for details.
• Clear Cache: UnRiskExcel stores previously calculated results internally. Whenever
an UnRisk calculation is encounter that was already calculated before, the result can
be directly obtained from the pool of cached calculations to avoid unnecessary
recalculations. When clicking this menu item all cached calculation results are cleared.
This forces the recalculation of subsequent UnRisk calculations.
• Open Logfile: Opens the UnRiskExcel log file, where error messages are written to.
The following menu items provide the UnRiskExcel parallelization feature and are only
visible in Excel 2003:
• Calculate Workbook in Parallel: This activates the UnRiskExcel parallelization
feature and calculates the active workbook. It is similar to using Excel’s keyboard
shortcut F9, but calculates the current workbook using parallelization. UnRiskExcel
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•
•

iterates over all worksheets, from left to right and calculates each worksheet
separately. Therefore, the user must ensure that formulas never reference worksheets
to their right. Otherwise, old values might be used.
Calculate Sheet in Parallel: This activates the UnRiskExcel parallelization feature
and calculates the active worksheet. This command can be used instead of the Excel
keyboard shortcut Shift + F9.
Calculate Selection in Parallel: This activates the UnRiskExcel parallelization
feature and calculates the current selection.

The following menu items are only visible if “Excel comment” was chosen as the error
reporting mode in the configuration file:
• Show Error Comments: It displays all errors that have occurred as Excel comments
that are attached to the erroneous cell. Previously attached comments will be
overwritten.
• Clear Error Comments: This deletes all currently displayed error comments.
Long running calculations can always be aborted by pressing the escape button (ESC).

6 Configuration File
The configuration file exists per user and contains the following options:
• Error reporting:
o Messagebox: When an error occurs, a message box is displayed to the user.
This interrupts further calculations until the message box is closed.
o Log file: Errors are not reported explicitly and are only logged in the log file.
o Excel comments: Allows the user to display error messages as Excel comments
that are attached to the erroneous cell. If this option is selected, Excel displays
the UnRiskExcel menu commands Show and Clear Error Comments.
• Automatic UnRisk startup: If this option is enabled, UnRisk will start automatically
when an UnRisk calculation is performed.
• Mathematica installation directory: You can explicitly configure the Mathematica
installation directory.
• Mathematica packages: This option determines which Mathematica packages are
loaded when UnRiskExcel starts.
• Logfile directory: Per default, the logfiles are placed in “C:\Documents and
Settings\Username\Application Data\UnRiskExcel\LogFiles\”. This location can be
customized.
• Log level: This option determines how many details are written to the log files.
Normally, it should not be necessary to change this value.
• Show “Calculate Workbook in Parallel” message: If this option is enabled,
UnRiskExcel displays a warning whenever “Calculate Workbook in Parallel” is used.
This warning mentions all limitations of “Calculate Workbook in Parallel”.
• Number of stored calculation results: UnRiskExcel stores previously calculated
results internally. Whenever an UnRisk calculation is encountered that was already
calculated before, the result can be directly obtained from the pool of cached
calculations to avoid unnecessary recalculations. The number of cached calculations
determines how many UnRisk calculations are cached by UnRiskExcel. A high
number increases the memory usage but speeds up calculations. Set this value to zero,
if UnRiskExcel must not store calculation results.
Where this file is located, depends on the Version of Microsoft Windows:
• Windows XP / Windows Server 2003
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C:\Documents and Settings\Username\Application Data\UnRiskExcel
• Windows Vista / Windows 7 / Windows 8 / Windows Server 2008
C:\Users\ Username\AppData\Roaming\UnRiskExcel
This folder also contains the UnRiskExcel log files. If an error occurs while using
UnRiskExcel, it is logged there.

7 Visual Basic
All UnRiskExcel commands that are available in the UnRisk menu can also be executed by
Visual Basic for Applications (VBA). For this, UnRiskExcelVBA must be added to the
references of your VBA project. Open the Excel VBA editor and on the Tools menu, click
References. In the following dialog, check UnRiskExcelVBA.

Figure 4: Dialog for adding the reference to UnRiskExcelVBA

The following UnRisk functions can be invoked by VBA code:
Function	
  UnRiskStartStop(ByVal	
  start	
  As	
  Boolean)	
  As	
  Boolean	
  
Function	
  UnRiskCalculateWorkbookInParallel()	
  As	
  Boolean	
  
Function	
  UnRiskCalculateSheetInParallel()	
  As	
  Boolean	
  
Function	
  UnRiskCalculateSelectionInParallel()	
  As	
  Boolean	
  
Function	
  UnRiskConvertWorkbook()	
  As	
  Boolean	
  
Function	
  UnRiskEditConfig()	
  As	
  Boolean	
  
Function	
  UnRiskOpenLog()	
  As	
  Boolean	
  
Function	
  UnRiskShowErrorComments()	
  As	
  Boolean	
  
Function	
  UnRiskClearErrorComments()	
  As	
  Boolean	
  
Function	
  UnRiskClearStoredCalculationResults()	
  As	
  Boolean	
  
	
  
Every function returns True if it was executed successfully and False otherwise.
For all functions that take the Boolean value start as their parameter, start determines if
the corresponding action should be started or stopped. UnRiskStartStop(True)	
  for example
starts UnRisk, while UnRiskStartStop(False) stops it.
The functions UnRiskShowErrorComments() and UnRiskClearErrorComments()	
   only

perform an action if error reporting was set to Excel Comments in the configuration file.
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The following code example starts UnRisk and computes the workbook using UnRisk
parallelization. When the calculations are finished, UnRisk is stopped.
	
  
Sub	
  RecalcWorkbook()	
  
	
  	
  	
  	
  On	
  Error	
  GoTo	
  ErrorHandler	
  
	
  
	
  	
  	
  	
  Call	
  UnRiskStartStop(True)	
  
	
  	
  	
  	
  Call	
  UnRiskCalculateWorkbookInParallel	
  
	
  	
  	
  	
  Call	
  UnRiskStartStop(False)	
  
	
  	
  	
  	
  Exit	
  Sub	
  
	
  
	
  	
  	
  	
  ErrorHandler:	
  
	
  	
  	
  	
  	
  	
  	
  	
  MsgBox	
  (Err.Description)	
  
End	
  Sub	
  

8 Frequently Asked Questions
Question: After updating UnRiskExcel, a warning message is displayed that my
configuration file was corrected. Was there a problem with my configuration file?
Answer: This message is normal and may occur after updating UnRiskExcel if configuration
options were added in the new UnRiskExcel version. The values of all existing configuration
options are preserved when updating UnRiskExcel. For new configuration options, default
values are added to your configuration file.
Question: All UnRisk formulas in my Excel workbook have the value #NAME? How can I
fix this?
Answer: Just run “Convert Current Workbook” from the UnRisk menu. When the conversion
has finished, you can recalculate the workbook.
Question: Why are the menu items Calculate Workbook in Parallel, Calculate Sheet in
Parallel and Calculate Selection in Parallel not visible?
Answer: Your computer does not support parallel calculations.
Question: I’m calling a Mathematica function with string arguments. Why does Mathematica
complain that my arguments are symbols instead of string values?
Answer: UnRiskExcel always tries to convert strings to Mathematica expressions. This has
the advantage that you can directly evaluate complex Mathematica expressions in Excel. To
force that a string value is passed, either put the value in quotes (“stringValue”) or apply the
function ToString[].
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